«

»

abr 13 2012

Imprimir Post

Protocolo OSPF – parte 4

Olá Pessoal,

 Conforme notificado nesse post iremos tratar um pouco sobre áreas dentro da arquitetura OSPF. Confira os posts anteriores para obter informações relevantes sobre o protocolo.

  No OSPF sempre iremos escutar e trabalhar com a area 0, chamada de ” área de backbone “. Essa seria a área de transito entre as diferentes áreas que podemos criar dentro do protocolo OSPF. Quando estamos pensando em um projeto de redes utilizando o OSPF, sempre devemos iniciar do ponto central ( área 0 ) e expandir para as áreas subjacentes, fazendo assim uma rede escalável e organizada.

  A área 0 deve ser o centro lógico da rede, ou seja, todas as outras áreas devem ter uma conexão física com o backbone. O motivo disso é que OSPF espera que todas as áreas encaminhem informações de tabela/sub-redes roteamento para o backbone, e este, por sua vez, se encarrega de disseminar estas informações para as outras áreas. Veja abaixo a demonstração dessa áreas.

 Baseado nas informações acima podemos avaliar alguns conceitos sobre a distribuição dessas áreas e algumas nomenclaturas definidas como ABR e ASBR.

  A definição para ABR e ASBR pode ser constituída como:

  • ABR = Area Border Router no qual é responsável por conectar duas ou mais áreas. Nesse tipo de equipamento nos temos os anúncios das redes ou database de topologia sendo anunciado através do LSA tipo 3.
  • ASBR = Autonomous System Border Router que conecta outros protocolos de roteamento ( redistribuição ) para dentro do protocolo OSPF. Normalmente isso é executado utilizando a area 0.

 Outro detalhe que podemos avaliar seria observando os diferentes tipos de informações que são trafegadas. Informações sobre rotas que são geradas e utilizadas dentro de uma mesma área são chamadas de “ intra-area routes ”, e são precedidas pela letra “ O ” na tabela de roteamento. Rotas que são originadas em outras áreas são chamadas de “ inter-area routes ”, ou “ summary-routes ”. Estas são precedidas por “ O IA ”, na tabela de roteamento. Rotas originadas por outros protocolos de roteamento e redistribuídas em uma rede OSPF são conhecidas por “ external-routes ”. Estas são precedidas pelas letras “ O E1 ″ ou “ O E2 ″, na tabela de roteamento. Quando temos múltiplas rotas para um mesmo destino, o critério de desempate em uma rede OSPF obedece a seguinte ordem: intra-area, inter-area, external E1, external E2.

  Quando mencionado sobre a redistribuição dos protocolos IGP ou EGP para o protocolo OSPF temos as diferenças sobre a nomenclatura ( E1 e E2 ), para qual podemos definir dessa forma:

  • E1 = As métricas definidas pelos protocolos anteriores a essa redistribuição ( ASBR ) serão incluídos para alcançar o próximo salto fora de seu AS.
  • E2 ( padrão ) = Os custos externos não são repassados para o protocolo interno que está rodando dentro do área interna.

  Vocês lembram quando foi comentado que todas as áreas OSPF deveriam conectar passando pela área de backbone? Pois é, isso não é regra. Surprised

 Como toda regra tem uma exceção e deveríamos ter nesse caso, pois não poderíamos ficar obrigatoriamente ” amarrados ” na condição de que qualquer área nova criada eu deveria ter uma conexão com nossa área de backbone, devido a algumas condições externas ( links, disponibilidade de viabilidade para chegar em seu ponto central, etc )  essa facilidade dentro do OSPF seria restrita. Para resolver esse problema existe as conexões através de link virtuais ” Virtual-link “.

  O link virtual OSPF é como uma “ VPN ” que integra uma área que não tem como se conectar diretamente ao backbone, através de uma área diretamente conectada a ele. É importante ressaltar que o artifício de “ virtual links ” é paliativo, ou seja, ele resolve um erro de design, e deve ser encarado como uma solução temporária.

  No exemplo acima podemos resolver da seguinte forma:

RouterA(config)# interface loopback 0
RouterA(config-if)# ip address 10.10.10.33 255.255.255.255
RouterA(config)# router ospf 100
RouterA(config-router)# network 172.16.20.128 0.0.0.7 area 0
RouterA(config-router)# network 10.10.10.33 0.0.0.0 area 0
RouterA(config-router)# area 0 range 172.16.20.128 255.255.255.192
RouterA(config-router)# area 1 virtual-link 10.10.10.30

RouterM(config)# loopback interface 0
RouterM(config-if)# ip address 10.10.10.30 255.255.255.255
RouterM(config)# router ospf 100
RouterM(config-router)# network 172.16.20.32 0.0.0.7 area 5
RouterM(config-router)# network 10.10.10.30 0.0.0.0 area 0
RouterM(config-router)# area 1 virtual-link 10.10.10.33

  Na próxima parte iremos falar sobre os tipos de LSA ( link state advertisement ) que estão disponíveis no protocolo OSPF.

  Espero que tenham gostado e aguardo comentários. Laughing

Abs,
Rodrigo

Posts relacionados:


0
0

Link permanente para este artigo: https://ciscoredes.com.br/2012/04/13/protocolo-ospf-parte-4/

Deixe uma resposta