«

»

abr 03 2012

Imprimir Post

Protocolo OSPF – parte 3

Olá Pessoal, 

  Vamos continuar com nosso tutorial sobre OSPF. O post anterior pode ser consultado aqui.

 Neste episódio iremos comentar sobre a configuração que podemos executar dentro do protocolo OSPF. Como todo protocolo de roteamento IGP ( RIP, EIGRP, OSPF ) que é habilitado em equipamentos Cisco temos 2 passos essenciais para configurar esse serviço:

  1. Habilitar o serviço através do comando router ospf [ id process ]
  2. Divulgar as redes que seus vizinhos OSPF devem aprender associando-se as interfaces com a área desejada network [ IP ] [ MÁSCARA ] [ area ]

  Quando definimos o [ id process ] estamos relacionando apenas com o processo local do roteador que você esta trabalhando, e o mesmo não tem nenhuma relação com os roteadores vizinhos que irão fazer a adjacência com ele.  Vários processos OSPF podem ser executados em um mesmo router, mas este procedimento não é recomendado, entretanto, já que cada instância consome grandes porções de CPU e memória. Em suma, um bom design não utilizaria mais de um processo OSPF em um mesmo router.

  Para comando [ network ] diferentemente do que ocorre na configuração de outros protocolos de roteamento, serve, no OSPF, para indicar quais interfaces participarão do processo, e quais as áreas OSPF a que pertencem. Esta é uma particularidade do protocolo.

  O ID da área é definido por um número inteiro compreendido entre 0 e 4294967295, e também pode assumir a forma de um endereço IP (ex: área 0 = 0.0.0.0).

  O campo referente a [ máscara ] é mencionada como uma ” máscara coringa “, que na verdade é a máscara padrão escrita de uma forma invertida. Nesse caso, como podemos calcular essa máscara?

A máscara coringa seria executada através de uma conta matemática simples que seria a subtração. Para esse cálculo sempre iremos subtrair utilizado a máscara como sendo um /32 ( 255.255.255.255 )

Padrão / 25      = 255.255.255.128
Subtração /32  = 255.255.255.255
Coringa /25      =   0  .  0  .  0  . 127

  No protocolo de roteamento OSPF podemos trabalhar com dois tipos de autenticação, para qual tem a função de criar uma segurança maior para o tráfego das tabelas de roteamentos entre seus vizinhos OSPF.

– Autenticação Simples:  Este método permite que chaves sejam configuradas por área OSPF. Routers em uma mesma área que desejem participar do processo de roteamento devem ser configurados com a mesma chave. A desvantagem deste método é que as chaves são trocadas pela rede, e podem ser facilmente interceptadas.

interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip ospf authentication-key ciscoredes

router ospf 10
network 172.16.0.1 255.255.255.0 area 0
area 0 authentication

– Autenticação MD-5: Neste método, uma chave e uma senha são configurados em cada router. O router usa, então, um algoritmo baseado no próprio pacote OSPF, na chave e no ID da chave para gerar um “message digest”, que é inserido no pacote. Este método permite a troca de senha sem a interrupção da comunicação.

interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip ospf message-digest-key 10 md5 ciscoredes

router ospf 10
network 172.16.0.1 255.255.255.0 area 0
area 0 authentication message-digest

 Baseado nesses conceitos temos uma vídeo-aula, para qual traz um laboratório com os comandos de configurações e exemplos de como a rede se comporta utilizando-se o protocolo de roteamento OSPF.

 Nessa vídeo aula temos informações que são mencionadas, para qual ainda não esta contemplado nessa parte, porém aguardem os próximos posts que iremos trazer as explicações.

 Deixem seus comentários. 🙂 e iremos falar no próximo post sobre áreas.

Abs,
Rodrigo

Posts relacionados:


0
0

Link permanente para este artigo: https://ciscoredes.com.br/2012/04/03/protocolo-ospf-parte-3/

Deixe uma resposta